Что делать после того, как вы установили Fedora

Читайте также:

комментария 43

  1. growl:

    Да.Очень познавательно.Спасибо!

  2. Статья, в которой систематизировано все самое необходимое для доводки Федоры в юзабельное состояние, очень полезная, т.к. экономит уйму драгоценного времени, предотвращая рысканье по всяким ресурсам в поисках необхдимых рецептов.
    Интересно, а можно ли запихнуть все это в какой-нибудь командный sh? Что осуществлять все это одним кликом 🙂

  3. Tigro:

    growl
    Пожалйста

    Mimino
    Моножно, все кроме видеокарточек, так как я не знаю как определить нужный драйвер для nvidia. Определить nvidia или ati легко.

  4. Если можно, то будет просто превосходно! Такой скрипт будет весьма полезен, например, в такой ситуации, когда нужно “довести до человеческого состояния” несколько компьютеров с Федорой. Когда их десяток и более – будет не до чтения и вникания в статью. А со скриптом будет просто супер – запустил его на всех компьютерах – и пошел себе кофеек попивать. Автоматизация, однако!:)
    Скрипт, конечно, должен быть диалоговым и содержать &&:)

  5. Mosga:

    А я всегда после установки гляжу в Personal Fedora Installation Guide (там еще рядом про сервисы рассказано – полезно давать почитать). Всем хорошая дока, кроме ориентации на ливну со всеми ее заморочками, freshrpms – наше все..

    Хотя со временем у меня тоже появилась большая-большая строчка для “yum install” и “yum remove”, которые выполняют большую часть подготовки системы..

  6. mx:

    Ну я хз но помоему если вы не писатель Java прог
    и JDK Вам не нужен то штатного ( по умолчанию JRE-170 )
    вполне хватает и работает он на уровне.

    По крайне мере так мне показалось хотя под ним у меня крутяться токо Azureus и Eclipse.
    ( эти двое у меня не дистрибутивные )

    Но может я и не прав …
    —mx

  7. Humanoid:

    amarok-extras-nonfree тоже уже давно ставить нет необходимости, ксайна хватает.

    последняя версия на ливне была для 1.4.4 и вышла 2006-Nov-02 11:31:51 =)

    Ява стоит стандартная, и в фоксе нормально пашут плагины, для абсолютного большинства прог её хватает, хотя есть пару которым подавай другую версия, поэтому стоят jdk 1.5 и 1.6 сановские (качал с офф сайта), но в стандартных путях не прописаны. jdk потому что сам являюсь java разработчиком….

  8. Tigro:

    mx, Humanoid
    А вот не все плагины работают с IcedTea. Вот типичный пример (любые цифры в качестве номера карты).

    Mosga
    Я же сказал, что не верю:) Вот объединятся вот тогда…

  9. mozgg:

    Некоторые вещи IcedTea совсем не тянет.
    К примеру, под ним Apache FOP у меня pdf-ки рисует ооочень долго.

    Последний раз это было (субъективно) 45-50 секунд на IcedTea против 5-6 секунд на jdk.

  10. Mosga:

    Ну я как-то уже сомневаюсь, что к 9 федоре они объединяться.. Хотя еще перед выходом 8 собирались успеть, а первых результатов объединения я еще в 7 ждал.

  11. Mosga:

    Эээ.. как это

    2. Март 2008, 15:02

    ???

    4 марта уже на дворе!

  12. Бил Гейц:

    Спасибо большое. Особенно про флэш для х86_64

  13. DRVTiny:

    Насчёт определения версии графических карточек – по-моему, проблема слегка надумана. Есть lspci, есть в конце-концов группа PCI SIG, стандартизующая в т.ч. поля Vendor ID и Device ID. Другое дело, что на написание такого скрипта время нужно… Самый же простой способ – брать и тупо пытаться заmodprobe’ить все три драйвера, начиная с самого свежего. Маловероятно, что у кого-то ещё есть GeForce 4 (хотя карта это была отличная, возможно, одна из лучших по соотношению тепловыделение/производительность за всю историю NVIDIA).
    А вообще Linux XP всё-таки лучший 🙂

  14. Freyd:

    Вопрос отначиающего. Я поставил Fedora 8 64×86-64
    Проблема в том чтоя через раз получаю доступ к NTFS разделам
    и собственной файловой системе Fedora 8

  15. Tigro:

    Freyd
    Что значит через раз? Поподробнее.

  16. Mosga:

    А кстати, разве nspluginwrapper уже реально работает с текущим флешем? Мне казалось, что он умеет работать в двух режимах: не работать вообще и постоянно падать.. Пока сижу на 32-х битном ффоксе ради этого.

  17. Tigro:

    Mosga
    Сколько я уж использую 64-х битную-то Fedora. Кажется с 6-й. Термин не работать вообще – я такого не видел. Термин постоянно падать, вероятно имеется в виду если сидеть и полчаса тыкать по youtube. Я давно уже с этим не сталкивался.

  18. Sunder:

    Кстати, если вы используете 64 бит Оперу то nswrapper вам не нужен, в последних билдах 9.50×86_64 есть поддержка 32 битных плагинов, в том числе флеша.

  19. Mosga:

    > Термин постоянно падать, вероятно имеется в виду если сидеть и полчаса тыкать по youtube

    Я с youtube общаюсь в основном посредством youtube-dl, но тем не менее меня крайне смущает приблуда, которая будет мне ронять браузер, если бы я полчаса тыкал по youtube. Потому что она может упасть в самый неподходящий момент, тем более там флеш по сути элементарный, а на некоторых сайтах на нем такое вытворяют, что о-го-го.

    Так что лучше посижу пока на i386, это лучше, чем иметь риск падений.. Я понимаю, что вкладки сохраняются, но все же – неприятно.

    > Кстати, если вы используете 64 бит Оперу то nswrapper вам не нужен, в последних билдах 9.50?86_64 есть поддержка 32 битных плагинов, в том числе флеша.

    Ох уж эта опера. Они бы лучше qt4-сборки поддержали бы, там хоть терпимо выглядящие темы появились, причем желательно динамическую сборку – а у них мало того, что все qt4-сборки статические, так еще под 64-бита их вообще нет..

  20. Ink:

    Достаточно поучительный материал, на лекции расскажу.

  21. Po:

    да ubuntu в этом плане легче.

  22. Коля:

    to DRVTiny
    [quote]Маловероятно, что у кого-то ещё есть GeForce 4[/quote]
    Глупости, на материнке без встроенной видюхи, GeForce 4 самое то. Современные видюхи нужны или для игр или для обогрева помещения.

  23. Хорошая статейка. У нашего community, кстати, тоже есть немало статей на русском по конфигурации fedora, в форме wiki – так что милости прошу просвящаться, и дополнять при желании!

    http://www.fedoramd.org/wiki/RU/Install

    С уважением, Женя
    сообщество пользователей Fedora в Молдове 🙂

  24. Это адобовское дерьмо под названием Acrobat Reader надо гнать взашей из линукса!

    http://asplinux.net/node/3537

  25. krege:

    Что означает ключ -g у mozilla-plugin-config? В зелпе, как ни странно, не нашёл.

  26. Tigro:

    Да, вы правы. Я тоже не вижу этой опции. Это строку я брал из Fedora Release Notes.

  27. Об установке плеера Xine забыли, что ли?

    Надо бы добавить его в этот мануал, DVD ведь тоже с комфортом хочется смотреть, а не ганяться за каждым его файлом 🙂

  28. Mosga:

    Так totem дистрибутивный после установки кодеков замечательно dvd показывает. С меню и всеми остальными вкусностями. Есть и другие приличные плееры на xine-lib; а xine с его тормозами и мерзким ui на кой сдался? Если кому-то нравится, пусть использует, но зачем обычным людям такое рекомендовать?

  29. Во-первых, с Totem я и начал, но он в упор отказался показывать DVD, и тогда я и вспомнил о Xine, который мне рекомендовал уважаемый Tigro.

  30. Mosga:

    Ну не знаю, у меня показывает.

  31. Игорь:

    Здравстуйте!
    у меня ошибка при установке

    mplayer xine-lib-extras-nonfree gstreamer-plugins-ugly

    Выдаёт вот это:

    Transaction Check Error:

    file /etc/pulse/client.conf from install of pulseaudio-libs-0.9.8-5.fc8 conflicts with file from package pulseaudio-libs-0.9.7-0.17.svn20071017.fc8

  32. Mosga:

    Ну во-первых, нужно сделать yum update. Во вторых – дистрибутив 32-х битный или 64-х битный?

  33. Tigro:

    Похоже, что 64-х битный. Если так, то нужно сперва сделать

    yum erase pulseaudio-libs-0.9.7-0.17.svn20071017.fc8.i386

  34. mikki43306:

    Пора обновить статью!
    tigro уже 8-2
    64 битный jdk тоже имеется

  35. Сергей Ларионов:

    Для девятой федоры это все работает очень хорошо, а вот для десятой – увы…..

    Ходя в /etc/yum.repos.d
    Определены необходимые репозитории :
    livna.repo
    russianfedora-nonfree.repo

    Тем не менее, на попытку установить кодеки для mp3 получаю :

    # yum install amarok-extras-nonfree

    No package amarok-extras-nonfree available.

    # yum install xine-lib-extras-nonfree gstreamer-plugins-ugly

    No package xine-lib-extras-nonfree available.
    No package gstreamer-plugins-ugly available.

    И где искать эти кодеки для десятки – я не могу понять. Но ведь не может быть, что бы никто из пользователей десятки не воспроизводил mp3 !!!

  36. Tigro:

    Ливны больше нет, теперь есть rpmfusion.

  37. Сергей Ларионов:

    > есть rpmfusion.

    Увы… Не помогло ! 🙁 Скачал пакеты с repo-файлами, установил их и запустил yum :

    # yum install amarok-extras-nonfree

    . . . .
    rpmfusion-nonfree | 2.7 kB 00:00
    rpmfusion-nonfree/primary_db | 68 kB 00:00
    Setting up Install Process
    Parsing package install arguments
    No package amarok-extras-nonfree available.
    Nothing to do

  38. Tigro:

    А амароку этот пакет не нужен. Он должен и так играть. Вообще посмотрите какие есть дополнения командой:

    yum search freeworld

  39. Сергей Ларионов:

    > А амароку этот пакет не нужен. Он должен и так играть.

    К сожалению, mp3 – не играет. И проблема эта на FC-9 (дома) была успешно решена именно

    # yum install amarok-extras-nonfree

    А вот на работе, с FC-10 почему-то не получается….

  40. Tigro:

    Тут несколько вариантов. amarok играет либо через gstreamer, либо через xine, значит нужны либо gstreamer-plugins-ugly, либо xine-lib-extras-freeworld.

    Опять же у меня амарок играет. Собственно используйте Russian Fedora и не будет у вас этих проблем.

  41. Сергей Ларионов:

    1) “amarok играет либо через gstreamer, либо через xine” – во время первоначальной настройки он (вроде) спрашивал, что использовать, но сейчас этого пункта в настройках найти не смог…

    2) gstreamer-plugins-ugly – инсталлировалась нормально, но эффекта не дало…

    3) xine-lib-extras-freeworld – Здесь возникает какая-то странная ситуация, которую я понять не могу. Если запустить

    yum install xine-lib-extras-freeworld

    то в результате получим :

    Error: Missing Dependency: libx264.so.58 is needed by package 4:mplayer-1.0-63.01_rc2.fc8_92.i386 (installed)

    Но эта библиотека есть :

    # locate libx264
    /usr/lib/libx264.so.58

    И именно та, которая нужна ! Более того, сведения об этой библиотеки должны быть в БД зависимостей :

    # rpm -qf /usr/lib/libx264.so.58
    x264-0.0.0-0.12.20080227.lvn9.i386

    Т.е. эта библиотека попала в систему не “через черный ход”, а при обычной установке пакета…

    Что самое загадочное, системный апдейтер все время предлагает обновить х264 но не может этого сделать…

    Если же посмотреть непосредственно содержимое репозитария
    download1.rpmfusion.org/pub/free/fedora/updates/9/i386
    то увидим, что пакет для FC-9 есть :
    x264-libs-0.0.0-0.15.20080613.fc9.i386.rpm

    А вот пакета для FC-10 :
    x264-libs-0.0.0-0.18.20080905.fc10.i386.rpm
    В репозитаарии
    download1.rpmfusion.org/pub/free/fedora/updates/10/i386

    нет !!!

    Мне кажется. что проблема растет именно отсюда…

  42. Serguei Khvatov:

    Сергей Ларионов:
    1. пункт в меню настроек называется движок или engine
    3. yum и говорит что libx264.so.58 у вас есть, но обновлять её (feature) нельзя, потому что она нужна для mplayer, который у вас старый, от 8-й версии. Обновите или удалите его.

  43. Сергей Ларионов:

    > Обновите или удалите его.

    А вот это – помогло !
    1) Снес mplayer
    2) yum install xine-lib-extras-freeworld
    Амарок заиграл mp3
    3) yum install mplayer
    mplayer нормально установился и работает !

    Спасибо !!!